What do I need to be able to pay with Siri?

To be able to use this feature, you need an Apple smartphone with an iOS version not older than 12.0.